Lead Time™ Release History

Lead Time™ provides a number of important and convenient facilities including automatic model calibration based on RMF or other monitor results, special support for configurations with Shared DASDs, Remote Copy, Dynamic Mirrors, as well as automatic model exploration for a range of I/O workloads.

To the best of our knowledge, current release of Xtract is year 2000 compliant. Lead Time is compliant   to the extent that the operating system is compliant.

Release 4.699 (Mar. 21, 2003)

  1. Includes a calibrated model of the STK V2X V2 controller.
  2. Introduces support for IBM ESS Model 800 and Model 800 Turbo controllers with partial support for RAID 10 mode.
  3. Includes full support for FICON channels at 1 Gb/s and 2 Gb/s.
  4. Includes usability enhancements: shortcuts for channel migration to FICON, redesigned dialog for volume delete function in Lead Time, and a new release of Xtgen removing the need to specify time periods.
  5. Corrects known bugs, in particular, in Xtgen with more than 8 LCUs.

Release 4.698 (Dec. 18, 2002)

  1. Introduces enhanced dialogs for Remote Copy workloads.
  2. Corrects known bugs, in particular, excessive queueing time problem in certain models of Remote Copy configurations.

Release 4.697 (Dec. 03, 2002)

  1. Corrects known bugs, in particular, excessive Host Director utilization problem in models of Remote Copy configurations.

Release 4.696 (Nov. 17, 2002)

  1. Corrects known bugs, in particular, a problem occurring when calibrating models with Parallel Access Volumes.

Release 4.695 (Oct. 31, 2002)

  1. Includes a calibrated model of the STK V2X controller.
  2. Includes models of the HDS 9900 upgraded controller and of the HDS 9900 V control unit. These models are based on technology evolution and manufacturer specifications and have not yet been calibrated to measurements. Results should be used with caution.
  3. Corrects known bugs.

Release 4.694 (Sep. 16, 2002)

  1. Includes a greatly improved set of functions for modeling Remote Copy configurations. In particular, a calibrated model of STK PPRC implementation has been added. See the User’s Guide or on-line help for a detailed description.
  2. A new facility in the model initialization function (Prime) allows to adjust unknown cache parameters. This is particularly useful in Open System environments or other situations where controller cache data is not available. Use the Execution and miscellaneous property page of the Set menu to activate this option.
  3. Includes a fully revised Lead Time manual and an updated on-line help.
  4. The password required to install the new release has changed. Please contact PALLAS International by e-mail, fax or phone to obtain the new password.
  5. There have been changes to the Lead Time modeling engine. In most cases, the difference in results is expected to be very minor and does not affect model calibration. If needed, a special compatibility mode allows to obtain exactly the same results as in preceding Lead Time version. Use the Execution and miscellaneous property page of the Set menu to activate this mode.
  6. Corrects known bugs.

Release 4.693 (Mar. 23, 2002)

  1. Includes usability enhancements for Join Prime function: the attained calibration accuracy is now displayed for all models at the end of the calibration process, and it is possible to select the model to load from this results panel.
  2. Corrects known bugs, including Fetch problems occurring for certain files.

Release 4.692 (Feb. 20, 2002)

  1. Includes several usability enhancements such as the ability to sort most device group synoptic dialogs and result panels by clicking on the heading of the column, improved Build Move functions, and better treatment of models with Remote Copy folders.
  2. Corrects known bugs.

Release 4.691 (Jan. 07, 2002)

  1. Includes several usability enhancements such as the ability to specify several Merge files in one operation as well as the ability to sort many device group synoptic dialogs and result panels by clicking on the heading of the column.
  2. A new facility has been added to suggest Pruning the model to remove devices with low activity rates. The threshold in terms of the percentage of total I/O rate can be specified in the Set menu in the Execution and miscellaneous property page. The facility then automatically determines the appropriate I/O rate for Pruning.
  3. Corrects known bugs.

Release 4.690 (Dec. 12, 2001)

  1. Corrects problems with buffer hit ratios when the controller type is changed from or to an STK control units. The buffer hit ratios are now preserved across changes in control unit type. Lead Time ignores the buffer hit specification for STK controllers unless directed to do otherwise in the new option Use buffer hits for StorageTek added to the Set menu in the Execution and miscellaneous page.
  2. Includes several usability enhancements such as resizeable synoptic dialogs for main, volume and load parameters, and persistent position of configuration and results graph windows. Lead Time now also automatically generates a Note after a model Merge operation, making it easier to keep track of which models have been merged. Notes are accessible from the Edit menu.
  3. Corrects known bugs, including glitches in sorting function used to sort volumes by I/O rates.

Release 4.687 (Oct. 05, 2001)

  1. Corrects an internal error problem occurring under certain circumstances in models with over 256 logical volumes.
  2. Includes internal improvements to model Save and Retrieve functions.
  3. The password required to install the new release has changed. Please contact PALLAS International by e-mail, fax or phone to obtain the new password.

Release 4.686 (Sep. 20, 2001)

  1. Includes an improved configuration drawing function as well as minor improvements in graph drawing function.
  2. Corrects known bugs in GTFSIM, in particular, related to report generation.
  3. Includes a new release of Xtract (4.3A) and Xtgen (1.01) to address OC4 abend problems occurring with the preceding release. The file menu has been rearranged. The Retrieve function corresponds to the old Retrieve Reset option, and the Overlay function corresponds to the old Retrieve Keep function.

Release 4.685

  1. Includes a calibrated model of the STK V960 controller.
  2. Includes a first implementation of Dynamic Mirrors (Business Continuance Volumes) for linearly and RAID-S mapped controllers. A new option has also been added to the Merge File function to allow to append selected logical volumes from a guest model into the current host model.
  3. The file menu has been rearranged. The Retrieve function corresponds to the old Retrieve Reset option, and the Overlay function corresponds to the old Retrieve Keep function.

Release 4.681

  1. Overhead values for several controllers including the EMC Symmetrix 8000 series and the IBM 2105 have been adjusted. This adjustment results in an improved performance prediction for the EMC controllers.
  2. Corrects known problems, in particular with channel data rates not being reset to consistent values for certain controller changes.

Release 4.680

  1. A new Merge option allows to copy cache hit ratios and percentage of reads for matching volume from one model to another. This is particularly useful in Shared DASD environments if the cache records are written only to the RMF data for certain system images.
  2. Corrects problems with the Join function for some models, as well as known problems with Remote Copy models.
  3. Corrects a problem in GTFSIM when the option to generate a report in addition to standard files is selected.

Release 4.671

  1. Includes a calibrated model of the STK Eclipse-2 controller.
  2. Includes an adjustment in the data rate for the FC-AL back end for the HDS 9900 controller to account for the 8/10 data encoding.
  3. A new release of Osx, a companion tool to process files exported from HDS GRAPHTrack utility supports version 4 of this utility. It is now possible to process export files for individual Logical Devices.

Release 4.664

  1. Corrects a glitch in the model of STK Eclipse controller. Under some circumstances, this glitch could cause a “dip” in the response time for an increased I/O rate. As a result of this correction, models with the STK Eclipse controller may produce somewhat different results. In most cases, the difference in results is expected to be minor.

Release 4.662

  1. Includes models of the IBM 2105 F ESS controller, the HDS 9900, and the EMC 8000 series.
  2. A new summary report option allows to print or save a brief summary of the workload. For Array Controllers, we now report main controller parameters and configuration data.
  3. Includes the latest drives for the HDS 9900 controller.
  4. Improved Help file and fully revised User’s guide.
  5. Provides support for records created from STK IXFP utility by our Xtract tool.
  6. Includes a beta release of Osx, a new companion tool to process files exported from HDS GRAPHTrack utility. This tool has been added to the Tools menu, and is also available as a stand-alone application. Instructions on using this tool are in the on-line Help for Osx.
  7. Tentative support for FiCON channels.
  8. Corrects known bugs.

Release 4.650

  1. Includes a model of the IBM 2105 ESS (Shark) controller. The model has been calibrated to the measurement data published by IBM during the controller introduction.
  2. Supports static and dynamic Parallel Access Volumes (PAVs or multiple exposures).
  3. Includes the latest drives for the HDS 7700-E controller.
  4. Improved Help file and fully revised User’s guide.
  5. Corrects known bugs.

Release 4.644

  1. Enhanced the Merge function to preserve the priming targets for guest volumes.

Release 4.643

  1. Corrected a bug occurring in some configurations with multiple Channel Path Groups. The result of this bug was an overestimation of the I/O response time for the affected configurations.
  2. Corrected minor problems with the previous implementation of the persistence of graphic attributes.

Release 4.642

  1. Improved calibration of the HDS 7700-E controller.
  2. Corrected bugs in Remote Copy representation, as well as several other bugs.
  3. New release of Xtract supports 4096 volumes.

Release 4.640

  1. A calibrated model of the STK Eclipse controller has been added.
  2. Graphics setting adjustments for the Graphics Server (e.g. by right clicking on the graph area) are now persistent throughout a Lead time session, and are stored in Lead Time profile upon exit.

Release 4.634

  1. Under certain circumstances, in previous versions of Lead Time, when Fetching some Xtract files additional volsers were created which did not exist in the actual system. This release attempts to prevent this from happening.

Release 4.633

  1. The default physical drive for the STK 9393-6 controller has been changed to Ultrastar 9ES.
  2. The “Incorrect DC index” bug occurring with models of the STK 9393-2 has been fixed.

Release 4.631

  1. The overheads for the STK 9393-6 have been adjusted to better track the benchmark values, and a new Ultrastar drive has been added to the menu of available physical drive types.
  2. A “random” bug occurring during the execution of models with Remote Copy has been eliminated.
  3. The user interface has been enhanced for the Remote Copy function, and other known bugs have been fixed.

Release 4.630

  1. The major change in this release is the introduction of support for up to 4 physical drive types for the HDS 7700-E controller. It is now also possible to represent ACP pairs with several drive types mixed on the same pair.
  2. The logical to physical mapping functions have been upgraded to fully support the STK 9393-6 controller with mixed RAID group sizes.
  3. As usual, incorporates program enhancements and known bug fixes.

Release 4.620

  1. Incorporates a model of the STK 9393-4 controller calibrated using measurement data. Lead Time supports mixed RAID array sizes for this controller.
  2. A model of the STK 9393-2 controller has been added, and existing model of STK 9393-4 correctly renamed.
  3. Incorporates several bug fixes and program enhancements. In particular, corrects a bug occurring with multiple open models when invoking the Join function (File menu).
  4. The installation program no longer unconditionally overwrites selected shared DLLs. In all cases, these DLLs are saved in Windows/Temp/LeadTime so that you can restore them if needed.

Release 4.612

  1. The default option has been changed to Serial channels for Array Controllers.
  2. Seagate Elite-23 and Elite-47 drives have been added to the menu of physical drive types for Array Controllers.
  3. Corrects a bug in the iterative execution (Model Run option) with Percentage I/O increments introduced in a recent release.
  4. Corrects an interface bug in Merge operations with individually selected devices or datasets.

Release 4.610

  1. Incorporates a model of the STK 9393-4 controller calibrated using a large number of measurement data.
  2. Overheads in the model of the IBM Ramac Virtual Array have been reviewed.
  3. Corrects certain interface bugs introduced in previous release.

Release 4.600

  1. This is a native 32 bit release with numerous enhancements and bug corrections. This being a major release, it is possible that some new problems have been created. We appreciate your patience and cooperation.
  2. Provides support for up to 4096 logical devices (volsers).
  3. Incorporates the latest Seagate Cheetah and IBM Ultrastar drives.
  4. Supports very large cache sizes in the companion tool GTFSIM.

Release 4.506

  1. Corrects a bug in the solution engine. The results of some models may now differ slightly from those produced by previous versions of Lead Time.

Release 4.503

  1. Corrects a problem occurring when initializing certain models of Shared DASD configurations. As a result, the calibration of such models should be generally more accurate now.
  2. increases the number of devices (volsers) that can be selected in the Merge dialog. This should reduce the occurrence of the “Too many selections” message.

Release 4.501

  1. Corrects a bug occurring when attempting to edit the properties of a Remote Copy connection.
  2. A new release of GTFSIM corrects the “insufficient memory” bug as well as problems when representing the HDS 7700 and 7700-E controllers.

Release 4.500

  1. Support for Hitachi Data Systems 7700-E controller, as well as EMC Symmetrix 5700, and 5430 control units. Allows to represent dual drive types and RAID group sizes for the HDS 7700-E .
  2. A new set of facilities to model Remote Copy configurations. Please check the help for Remote Copy Model menu option.
  3. The maximum number of device groups has been increased to 416 (13 “strings” of 32 logical devices).
  4. A new release of GTFSIM adds the HDS 7700-E controller and the IBM Ramac Scalable Array.

Release 4.400

  1. Support for RAID-1 mapping in the HDS 7700 control unit, as well as significantly improved support for the definition of mixed mapping for controllers that support mixed mapping (e.g. RAID-S / linear for the EMC Symmetrix, RAID-5 / RAID-1) for HDS 7700. RAID-1 mapping is represented as linear with mirroring. Please check the help for Array Controller configuration for details.
  2. The current logical to physical mapping can be printed out in the Logical device mapping panel. This panel is now displayed following remapping through the Remap function in the Default maps dialog. The Remap function itself has been revised and enhanced. The quick print out of the mapping coupled with the display of physical device and RAID bank numbers provide an easy record of the mapping suggested by the Remap function.
  3. Recently introduced subtype 5 RMF records are now supported providing cache hit information for improved model calibration. Also supported is the device number information from RMF so that, if this information is present in the .SMF file produced by Xtract, Lead Time can order the displays by RMF device numbers. This feature can be selected through the Other option in the Set menu.

Release 4.335

  1. An enhanced configuration display which now includes device or RAID group numbers. This should enhance the usability of the logical to physical mapping display.
  2. The total percentage of write I/Os has been added to the main model display and global model parameters report.
  3. In the device targets display (View menu), it is now possible to include I/O rates. To select the quantities to be included in the display, minimize the graph so as to uncover the See button which gives you access to the selection dialog

Release 4.333

  1. Based on recent measurements, a better calibration of the HDS 7700 control unit, the EMC Symmetrix 5000 series, as well as of the IBM Model 3 controller. Adjustments were also made for the IBM Model 6, and the IBM RAMAC control units.
  2. A substantially calibrated model of the STK Kodiak controller is now enabled. This control unit appears as the RAMAC Scalable Array in Lead Time. Also included are RAMAC Virtual Array and RAMAC Electronic Array. The calibration for RAMAC Virtual Array is based on values for STK Iceberg taking into account internal improvements and new physical device.
  3. The ability to model the RAID-S implementation in the Symmetrix 5000 series. Also, for the Symmetrix 5000 series, it is now possible to model adaptive staging using the Staging method parameters accessible from the Load defaults in Build menu.
  4. Several usability improvements and bug fixes. Among the usability improvements, the ability to define directly the number of logical devices from the main dialog in the Build menu. For quick studies without actual I/O rates to volumes, it is now possible to define a total I/O rate and a specified I/O skew in the same Build main dialog.

Release 4.321

  1. A first shot implementation of the Encore Infinity SP controller. The model is not yet calibrated so that results should be used with caution.

Preceding Releases

  1. By default, multiple strings are now compacted when Retrieving saved models, and also when Fetching files created by Xtract. You can change this behavior through the Pack Strings option in the Other dialog in the Set menu.
  2. A new Calibration report has been added to show the relative overall deviation from calibration targets. This report is only meaningful following model calibration. The priming of models with Array Controllers now attempts to adjust the percentage of DASD buffer hits, as well as the device zero seeks and latency factors. If you wish to disable this adjustment, you can do so in the Other option of the Set menu.
  3. Both Xtract and GTFSIM support now merging of I/O traces from the same or different systems. This should prove to be particularly useful for migration studies where the I/O workload from several smaller controllers is ported to a single larger Control Unit. You will now be able to use GTFSIM to assess the combined cache behavior of the merged workloads. The GTFSIM specific information has been included in the GTFSIM help file (search for multiple traces) . The Xtract information can be found in the Xtract documentation
  4. The mapping of logical to physical devices for mapped controllers is now included in the reports printed or filed (in ASCII, comma delimited ASCII or DIF formats) unless you select the results only option (Report in Set menu).
  5. A new release of the GTF based simulation tool GTFSIM corrects known bugs, and allows the specification of a maximum number of track accesses to consider in the simulation.

Click here to access Pallas Lead Time latest features.